最近在写flutter和原生的混合项目,由于重装了系统,AndroidStudio下载的最新的额了4.2.1版本,配置好环境后,用flutter项目可以正常运行,但是打开原生项目就死活跑不起来了,一直报错。

报错信息如下:

Gradle sync failed: Sync failed: reason unknown 

网上搜了一个遍,各种清理缓存和rebuild也不行,可以说是也没有找到对应的解决方案

后来在一个老哥那里的视频看到,升级新版的AndroidStudio后把build.grade中的grade版本改成与AndroidStudio一样就可以了,随后我试了一下,果然可以!

就是下面的这个玩意,后面的版本改成和AndroidStudio一样就好了

    dependencies {
        classpath 'com.android.tools.build:gradle:4.2.1'
    }
最后修改:2021 年 06 月 22 日 10 : 32 AM
如果觉得我的文章对你有用,请随意赞赏